Импорт модели из таблицы Excel и AutoCAD

Импорт модели из созданной по шаблону таблицы Excel

Функция позволяет импортировать геометрию трубопровода из таблицы Excel, созданной по специальному шаблону. Файл шаблона для таблицы (Coordinate Import Example.xlsx) расположен в папке с примерами: Справка> Примеры расчета

Откройте файл примера (Coordinate Import Example.xlsx).

В файле есть возможность задавать несколько видов объектов: труба (run), отвод (bend), арматура (valve), тройник (tee), фланцевое соединение (flange), переход (reducer). Для каждого объекта задается две координаты его начальной и конечной точки. Все точки, которые совпадают по координатам будут автоматически "склеены". Для тройников задается три точки. Номинальный диаметр автоматически конвертируется в реальный диаметр в зависимости от выбранной группы стандартов (ГОСТ, ASME, EN).

Задайте необходимую геометрию модели. Затем сохраните файл с новым именем в формате csv (Файл > Сохранить как)

Затем создайте новый файл расчета в СТАРТ-ПРОФ. И импортируйте файл csv: Файл-> Импорт > Из таблицы Excel (.csv)

Для корректного экспорта и чтения файла, необходимо чтобы на обоих машинах, где производится экспорт из СТАРТ-ПРОФ и импорт в MS Excel были одинаковые настройки разделителя целой и дробной части и разделитель элементов списка. Для их изменения: Пуск > Параметры > Время и язык > Формат даты, времени и региона > Дополнительные параметры даты и времени > Региональные стандарты > Дополнительные параметры

Импорт модели из AutoCAD

Функция позволяет импортировать геометрию трубопровода из AutoCAD.

Перед извлечением данных, нужно сконвертировать Pline и 3Dpoly в Line. ARC пока не поддерживается.

Нарисуйте чертеж трубопровода линиями в AutoCAD. Затем запустите функцию "Извлечение данных" (в меню Аннотации). Выберите экспорт только геометрии и только координат начала и конца каждой линии

Откройте полученный файл в Excel и сохраните файл с новым именем в формате csv (Файл > Сохранить как)

Затем создайте новый файл расчета в СТАРТ-ПРОФ. И импортируйте файл csv: Файл-> Импорт > Из AutoCAD (.csv)

Доступ из меню

Файл-> Импорт > Из таблицы Excel (.csv)

Файл-> Импорт > Из AutoCAD (.csv)